Jump to content

ASI2600MC OSC and INDI/Ekos - Check driver white balance setting


Astrobdlbug
 Share

Recommended Posts

I have spent best part of 2 weeks  getting to grips with why I could not get calibration frames to work with the subs taken with my new ASI2600MC.
Took long subs, short subs, used white A4, used ND film - and this is a setup I have used for years on mono calibration, so I was really frustrated why I was failing in this calibration step with ASI2600MC.

I may be late to the party and/or not being paying attention, but after much Googling it turns out that the native ZWO driver for ASI2600MC OSC has by default a scaled white balance with setting WB-R (red) = 52 and WB-B (blue) = 95 - even when you select RAW/FITS as the output.

These two setting should be set to WB-R=50 , WB-B=50

With the default ZWO driver setting WB-R=52 and WB-B=95 my  calibration frames, darks and flat were adding colour cast and gradients all over the  final integration.

Setting WB-R/WB-B to 50/50 I have now got 'neutral' calibration frames and my intergration looks how I expected and I have RGB channels that I can balance.
Unfortunately all my subs were captured with the default(wrong) white balance - so I've lost colour depth information in calibration I think

So..... Before using this excellent camera - check the driver colour balance in your capture software and set it to 50/50

When I discovered what I needed to search for I found this very useful explaination from Sharkmelly :

"This means the data are no longer raw because it has been manipulated. Without going into too much technical detail, this introduces the possibility of causing coloured concentric banding in the background of your images.  Always use 50R/50B to acquire data.White balance is best left as a post-processing step."

So hopefully I get now get on and process my images from the hot week we had along with an  unprecedented run of clear skies, hopefully post into imaging section in a few days

Bryan

Link to comment
Share on other sites

7 hours ago, Astrobdlbug said:

I have spent best part of 2 weeks  getting to grips with why I could not get calibration frames to work with the subs taken with my new ASI2600MC.
Took long subs, short subs, used white A4, used ND film - and this is a setup I have used for years on mono calibration, so I was really frustrated why I was failing in this calibration step with ASI2600MC.

I may be late to the party and/or not being paying attention, but after much Googling it turns out that the native ZWO driver for ASI2600MC OSC has by default a scaled white balance with setting WB-R (red) = 52 and WB-B (blue) = 95 - even when you select RAW/FITS as the output.

 

These two setting should be set to WB-R=50 , WB-B=50

 

With the default ZWO driver setting WB-R=52 and WB-B=95 my  calibration frames, darks and flat were adding colour cast and gradients all over the  final integration.

Setting WB-R/WB-B to 50/50 I have now got 'neutral' calibration frames and my intergration looks how I expected and I have RGB channels that I can balance.
Unfortunately all my subs were captured with the default(wrong) white balance - so I've lost colour depth information in calibration I think

 

So..... Before using this excellent camera - check the driver colour balance in your capture software and set it to 50/50

 

When I discovered what I needed to search for I found this very useful explaination from Sharkmelly :

 

"This means the data are no longer raw because it has been manipulated. Without going into too much technical detail, this introduces the possibility of causing coloured concentric banding in the background of your images.  Always use 50R/50B to acquire data.White balance is best left as a post-processing step."

 

So hopefully I get now get on and process my images from the hot week we had along with an  unprecedented run of clear skies, hopefully post into imaging section in a few days

 

Bryan

 

This problem was fixed in NINA and with ASCOM drivers. Looks like the driver has not been updated on INDI.

Link to comment
Share on other sites

3 hours ago, AstronomyUkraine said:

This problem was fixed in NINA and with ASCOM drivers. Looks like the driver has not been updated on INDI.

Yes - I gathered that from my investigations and why I flagged this for INDI/EKOS so hopfully help someone else find out more quickly than i did that when using Rpi and INDI andcheck the driver  white balance and update the settings.

 

Hopefully this site has some indexing linked to search engines and having this posted can benefit other imagers

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...