Jump to content

Can't get EKOS auto focus with ASI2600MC OSC to work


Astrobdlbug
 Share

Recommended Posts

Hi,

 

This is a rather specific issue related to using INDI/EKOS on raspberry Pi4 with an ASI2600MC, but hopefully someone has experience or can perhaps add to the somewhat sparse knowledge out in internet land on this topic.

 

I have been using the EKOS autofocus very succesfully with both of my imaging rigs, widefield using a skywatcher motor focusser controlled by a HitecAstro DC focus module and a Moonlite HiRes stepper with associated controller for my refractor using my mono ASI1600MM.

 

Now using the ASI2600MC OSC in both of my rigs recently (July for SADR region widefield and last week for Cygnus loop West, refractor) - the EKOS autofocus goes off into the weeds, what I mean is that I bring it near a good focus manually by eye, then set autofocus running and it appears to select noise as stars and then goes completely out of focus and gives up or says it has completed but in reality its miles off.  I does not seem to find the stars and place the red circle around the diameter of the selcted focus star, rather it looks like it selects multiple edges around the star and then tries to focus on them. I have tried auto slect star and also manual selecting focus star - both end up with same non-focussed end result.

 

My baseline as used with mono camera is to use SEP mode to select stars and then polynomial autofocus method, with an initial step of 40 with multiplier of 5.

This method didn't work with ASI2600MC so I then tried to use full field with a slection of 40-80% FOV still with SEP to select stars and linear solve method - took an age had over 35 iterations to not focus !!

I am now using exposure of 3s with OSC with mono was using 1.5s exposure, both with gain 100.

 

I also set FITS viewer so it does not debayer or display in colour - so I am wondering what image or version of image the autofocus is actually using - does it debayer in background and use say blue channel ? - I dont think its doing this as debayer takes quite a lot of performance and thats not notceable on RPi CPU useage graphic on screen display.

 

Anyone got any suggestions as to what settings may have greatest influence on this EKOS auto focus algorithm with an OSC camera - I am going to load my dark master into the autofocus application next session to see if that helps - but the ASI2600MC has so little noise in its output images I am not hopeful that is the solution

 

Any help or suggestions most welcome

 

Bryan

Link to comment
Share on other sites

I don’t have the 2600 Bryan but I will check out what my autofocus settings are and maybe we could compare. My focusers are Lakeside but the algorithm may be similar. I also have the Deep Sky Dad but not had chance to try it out yet with all the clouds.

 

I recall having similar issues and was able to correct it with my current settings. I will have a look tomorrow and post the results.

  • Thanks 1
Link to comment
Share on other sites

Initially I was using the below settings and it was all over the place and was failing after about 30 iterations. I don't use these now and if I remember correctly these are the default EKOS settings.

image.png.fff54da7833bc272c10beabd69c98e2e.png

 

image.png.f19a8414ad2983c442a7a98f28b89404.png

 

image.png.c89afc43bd2bd0ccb9bf0e9d9843ffb1.png

 

Here are my current settings and they work great - Lakeside focusers.

image.png.0664607d2e25c70c97cc15843f6f599e.png

 

image.png.ad61d2384bf78efe9726d7208b4d1dbc.png

 

image.png.36e0dcb4253349b77d9f37c656a9a809.png

 

The only differences between scopes fitted with the Lakeside focusers are the Backlash settings. I measured the backlash with a dial test indicator and they were considerably different. I have not yet measured the backlash for the RedCat with its DeepSkyDad focuser but I think it is very little.

 

All the focusers have temperature probes but I have not been brave enough to enable auto focus when temperature deviates  >1 C - yet!!

 

I can get good focus within 8 or9 iterations now.


 

  • Thanks 1
Link to comment
Share on other sites

4 hours ago, TerryMcK said:

Here are my current settings and they work great


thanks - appreciate this information , I’ll give these setting a try when clouds eventually vacate the sky for an evening.

I had a quick look at my settings again this morning and the backlash is gray’d out so can’t input a value there … can’t see why 

 

1 hour ago, MarkAR said:

Couple of things which might help


Thanks again - will tweak these settings as well - it’s definitely going to be trial and error and do one change at a time as there are a lot of variables in play with this auto focus process

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...